邮 箱:
   
密 码:
注册

Android statu提示:Error:(1, 0) Plugin is too old, please update...

習慣沉默 分类: 电脑/IT- 编程语言- Android 被浏览 1904 次 很久之前

举报

Android studio 2.0 在配置环境opencv环境时候,提示插件太老了,怎么更新?
Error:(1, 0) Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to "9bd2076e9cc722f05ab125f51eef2c34445fd"
Fix plugin version and sync project(点了修复没有用?!)
Open File
 
我有更好的答案∨
 图片
验证码 (看不清,点图换一张)
出错啦!!!
小麻雀
采纳
小麻雀
采纳率:84% 10级 举报 很久之前
第一种,最简单,但是不推荐这么做
将工程最后面的总的build.gradle(Project:....)文件里的classpath进行修改:
classpath 'com.android.tools.build:gradle:2.0.0-alpha9'
改成
classpath 'com.android.tools.build:gradle:1.5.0'

或者
classpath 'com.android.tools.build:gradle:1.3.0'
这是不推荐的方法,但是简单可行 

第二种方法,这才是解决方法的正确方式
首先下载
https://services.gradle.org/distributions/gradle-2.10-all.zip
当然如果有新的,也可以下新的,这个如果你不知道下载地址,其实studio会提醒你的
然后打开路径
android-studiogradle
 将下载的文件夹放到这里
然后打开studio,settting-》build,execution,deployment->gradle    修改路径到
android-studio/gradle/gradle-2.10
然后就可以了,如果提示你的sdk版本不匹配,你直接点update就行了,接着accept几秒钟就好。

当然,也许你应该修改项目的的设置,打开项目位置
MyApplicationgradlewrapper
修改文件gradle-wrapper.properties
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip
类似这样的就可以了
评论00
 

全部回答(1)

分享: 

举报内容:

举报类型

举报原因


举报说明

详细的描述及证据可以帮助管理员更快速处理违规内容